General app slowness

Incident Report for Redlist Software

Resolved

We are no longer seeing timeouts throughout the system.
Posted Jun 30, 2026 - 12:17 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2026 - 19:59 MDT

Investigating

There have been multiple reports of slowness on the app, both on mobile and on web. We are investigating potential causes.
Posted Jun 29, 2026 - 15:16 MDT
This incident affected: Web Application and Mobile Application.